Linux下安装Django1.2和Mysql-Python

写这个教程主要是因为今天想试用一下django1.2,需要个django的运行环境。也当做个记录,让其他人也能顺利的搭建django环境。
在安装之前,首先要保证你的系统中已经配置python环境,我使用的python版本是2.6.2,本文安装的是django1.2.1,它需要python2.4以上的版本。
安装django
1.下载
你可以下载2种版本,稳定版本如下方式:
cd /usr/local/src
wget http://www.djangoproject.com/download/1.2.1/tarball/
最新版本,这个需要直接从svn中下载:
svn co http://code.djangoproject.com/svn/django/trunk/
注意svn命令需要安装了subversion,大家可以找相关教程,这里就不赘述了。
2.安装
tar xzvf Django-1.2.1.tar.gz
cd Django-1.2.1
python setup.py install
到这里django就安装完了,此时相关的django模块会安装python安装目录的site-packages文件夹下,并且会django的管理脚本目录会添加到系统环境变量中。
安装mysql-python
顾名思义,mysql-python是一个用来在python中访问mysql数据库的类库,django中默认就是用这个类库来访问mysql。
1.下载
wget http://downloads.sourceforge.net/project/mysql-python/mysql-python-test/1.2.3c1/MySQL-python-1.2.3c1.tar.gz?use_mirror=ncu
2.修改site.cfg文件
修改site.cfg文件夹主要是告诉myslq-python的模块,mysql_config文件的路径,注意不是my.cnf文件。
将文件中下面这行配置的注释去掉,将“/usr/local/bin/mysql_config"改为你系统中mysql_conf文件所在路径
#mysql_config = /usr/local/bin/mysql_config`
3.安装
tar zxvf MySQL-python-1.2.3c1.tar.gz
cd MySQL-python-1.2.3c1
python setup.py install
常见问题
1.Python版本不对
如果系统中有多个版本的python话,建议将django和mysql-python安装到高版本的python中。方法是安装时将python换为pythonxx,比如python2.6.2,安装命令就是:
python26 setup.py install
2.找不到libmysqlclient
开始使用mysql-python可能都会遇到错误提示如下
django.core.exceptions.ImproperlyConfigured: Error loading MySQLdb module: libmysqlclient_r.so.16: cannot open shared object file: No such file or directory
解决方法是:将“mysql安装目录/lib/mysql"目录下的libmysqlclient_r.so.16拷贝一份到“/usr/lib"目录。
3.在windows 64位环境下安装mysql-python
这个不是本文的主要内容,算是一点补充吧,也不单独写了。在windows安装这些基本就是傻瓜化了。但是一定要下载到合适的安装文件,在64的系统下用32位的安装文件对mysql-python是行不通的。为了免于大家四处寻找,这里给大家提供一个可以下到各个版本的链接,根据你的情况下载吧。
最后,说个题外话,django1.2.1,高效,便捷,灵活,新颖的开发模式,真的让人惊叹!!不知道用过的同学能不能够谈谈感受。